联系我们联系我们
电子邮箱电子邮箱

OSPF综合实验配置

[复制链接]

该用户从未签到

clye 发表于 2020-9-30 17:50:18
45 0
OSPF综合实验配置
实验一:配置点到点,点到多点链路
实验二:配置基本的OSPF
实验三:配置OSPFover NBMA网络类型
实验四:配置Stub、TotallyStub
实验五:重分布Rip进OSPF并配置NSSA
实验六:配置虚链路
拓扑图:

整体实验环境:
1、本人用的是dynamips,并在一台机子上完成,电脑配置AMD2800 1.61GHZ,
  512M内存。建议:用好点的电脑,或者用dynamipsgui的重分布用两台或者更多的计算机完成实验。
2、每台路由器一打开就进行如下配置:
en
conf t
hos router1   //给路由器命名,便于识别。
line con 0   //进入控制接口consol口
logg syn   //同步
exec-time 0 0   //不超时 注意:这几步是有大作用的,实践证明
exit
inter lo0   //设置Routid,即Loopback0
ip add 10.0.0.10 255.255.0.0
exit     
router ospf 10   //在有多个回环接口的情况下最好手动指定RouterID
router-id 10.0.0.10
end
write     //最后先保存下,防止意外发生。。
上面这些基本配置在后面的实验里就略了。。
3、实验中用Loopback模拟网段,如图中的L:172.16.0.0/24
4、为了拓扑图简洁一些用的都是网段,实验中可以自己配置不同的IP。

实验一:配置点到点,点到多点链路
实验环境:
如图:先开R1R2 R3 R4四台路由器,建立帧中继环境(这是一个比较麻烦的事,要细心不能
有一点的马虎,不然你配置命令正确也是没用的。有没有配置好,看你用EncapFrame-relay
,No shut后看Lineprotocol是否是UP的,如果是Down说明你的物理配置是错的。)
实验要求:
R1与R3R4建立点到点的链路R2与R3R4建立点到多点的链路,即·它们能Ping通

具体配置:
R1:
conf t
inter s0/0
encap frame-relay
(frame-relay lmi-type ansi) //如果是用模拟器,这条可以不用配置,默认就是Ansi而且
不支持其它的。
no shut
inter s0/0.1 point-to-point
ip add 172.17.0.1 255.255.255.0
frame-relay interface-dlci 102
inter s0/0.2 point-to-point
ip add 172.18.0.1 255.255.255.0
frame-relay interface-dlci 103
no shut
end  //查看结果要有两个UP,高端路由器可以用doshow 这种命令来调用。
show inter s0/0
show run
R2:
conf t
inter s0/0
encap framr-relay
no shut
inter s0/0
ip add 172.20.0.2 255.255.255.0
frame-relay map ip 172.20.0.3 104 broadcast
framr-relay map ip 172.20.0.4 105 broadcast
do show run  //查看结果
R3:
conf t
inter s0/0
encap frame-relay
no shut
inter s0/0.1 point-to-point  //子接口0.1与R1形成点到点连接
ip add 172.17.0.3 255.255.255.0
frame-relay interface-dlci 201
inter s0/0.2 multipoint  //子接口0.2与R2形成点到多点连接
ip add 172.20.0.3 255.255.255.0
frame-relay map ip 172.20.0.2 401 broadcast
end
R4:
inter s0/0
encap frame-relay
no shut
inter s0/0.1 point-point
ip add 172.18.0.4 255.255.255.0
frame-relay interface-dlci 301
inter s0/0.2 multipoint
ip add 172.20.0.4 255.255.255.0
frame-relay map ip 172.20.0.2 501 broadcast
end
检测:互Ping
发现:点到点连接的R3不能与R4相Ping
点到多点的也一样。。
而且点到点的网络不能与点到多点的相通。。
在实验三中将解决这个问题,实验所有网段的互通。。
  先要知道:一个点到多点网络被看作若干具有一个或多个邻居的点到点网络

实验二、配置基本的OSPF
实验环境:
在实验一的基础上,R1R2 R3 R4路由器
实验要求
根据图来配置OSPF
R1:(最开始说的基本配置和接口IP配置都略了)
conf t
router ospf 10
router-id 10.0.0.10
net 172.17.0.0 0.0.0.255 area 1
net 172.18.0.0 0.0.0.255 area 1
net 172.16.0.0 0.0.0.255 area 0  //loopback接口,做为一个网段
net 172.22.22.0 0.0.0.255 area 0 //e0接口
还是很简单的。
其它的同上一样的格式。。略
查看信息:(最重要的)
show ip ospf //查看ospf的配置基本信息。
show ip ospf inter e1/0 //查看接口的OSPF信息。
具体的解释在另一个笔记总结里有关于怎样来看信息。
实验三、配置OSPFover NBMA网络类型
实验环境:在实验一二的基础上,R1R2 R3 R4路由器
实验要求:实现各网段的互通。
   R1和R2建立邻接关系
配置过程:
分析:
通过在R4上Show ipospf可以看到把R3作为下一跳了,但R3和R4之间没有东西联系。原来是
因为配置成broadcast模式,链路被看作成一条多路访问链路,如以太网;所以路由器R3认为路由器R4和自己连在一起,共同在同一网段,和以太网一样,因为G和H没有PVC连接,G 没有2 个Layer 2-to-Layer 3地址映射,路由器R3的ip 地址不能映射到帧中继头中,在以太网中,可用MAC来映射。在帧中继中要用DLCI来映射IP地址。
方法一:配置PVC映射
R4:
conf t
inter s0/0.2 multi
frame-relay map ip 172.20.0.3 501 broadcast
R5:
conf t
inter s0/0.2 multi
frame-relay map ip 172.20.0.4 401 broadcast
检测一下,可以Ping通
方法二、配置成point-to-multipoint
inter s0/0.2 mu
no frame-relay map ip 172.20.0.3 501 broadcast //先去掉PVC两个路由器都去掉刚才配
R2:
inter s0/0
ip ospf network point-to-multipoint
R3:R4:
inter s0/0.2 mul
ip ospf network point-to-multipoint
测试下,都Ping通了。。。
RR1和R2建立邻接关系
按拓扑图把接口都配置上并打开。。。
打开了后
show cdp ne //查看是否建立了连接
debug ip ospf adj //查看建立关系的过程
show ip ospf nei //查看邻居的状态
show ip pro  //查看用的协议
实验拓扑图
111.jpg
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

发表新帖

小黑屋|手机版|Archiver|华盟论坛 ( 京ICP备11013304号-8 )

Powered by 华盟网 X 8.0  © 2001-2013 Comsenz Inc.  华夏黑客同盟